Search for an idea

Enable by default to click through transparent areas

Elements and especially screen parts are often positioned one on top of the other. Many times, the canvas area of the screen part is large and overlaps other parts of the prototype. It happens a lot when the screen part has an animation effect (a panel appears upon hovering over a specific area of the screen part, e.g., a menu dropdown). It will be great to allow clicking through a screen part when no objects are placed on it, or when they are invisible/transparent.

3 votes
Vote
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    I agree to the terms of service
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    Gil shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →
    AdminIndigo Studio Team (Product Team, Indigo Studio) responded  · 

    I may be misunderstanding the scenario. Correct me if that is the case.

    There are two ways to adjust visibility of a UI element. One is by manipulating the transparency slider. But this approach does not remove the UI element.

    The other way is to use the explicit hide option. Which is the “eye” in the property panel. You can also right click on top of a UI element and access hide/unhide from the context menu.

    2 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      I agree to the terms of service
      Signed in as (Sign out)
      Submitting...
      • Gil commented  ·   ·  Flag as inappropriate

        What I have suggested is that when a screen part is empty (either really empty of with items set to transparent) item underneath it will be accessible (i.e., clickable).

        See for example: http://indigodesigned.com/share/phn8bbtbuxpz

        While in most cases you can work around the it, the seamless solution would be (IMHO) the above suggestion.

      • AdminIndigo Studio Team (Product Team, Indigo Studio) commented  ·   ·  Flag as inappropriate

        Hi, Gil.

        If I understood the attached image correctly, you have a screenpart that's been placed on top of the current view, and you have set the transparency to 100% so that it's not visible. I take it when pressing #1, the screenpart which was not visible earlier is now shown, and in the process covers #2.

        Have you already tried hiding it instead instead of using the transparency slider?
        PROPERTIES ----> HIDE | LOCK
        Hide is represented by the "eye" icon.

        To show it again, you can right click in the same area, and find it in the list of "elements under the cursor" to toggle the visibility again.

        If I have misunderstood, can you shoot an email to indigo@infragistics.com so that we can take a deeper dive?

      We moved!

      Feedback and Knowledge Base